× {{alert.msg}} Never ask again
Get notified about new tutorials RECEIVE NEW TUTORIALS

NameError: uninitialized constant ActiveRecord::ConnectionAdapters::PostgreSQLAdapter::TableDefinition

Simone Carletti
Mar 21, 2015
<p>Apparently, the <code>activerecord-postgis-adapter</code> gem is <a href="https://github.com/rgeo/activerecord-postgis-adapter/pull/145" rel="nofollow">not yet compatible with ActiveRecord 4.2</a>.</p> <p>Either use the standard <code>pg</code> gem (that is supported natively by ActiveRecord), or downgrade to 4.1.</p> <p>This tip was originally posted on <a href="http://stackoverflow.com/questions/27676646/NameError:%20uninitialized%20constant%20ActiveRecord::ConnectionAdapters::PostgreSQLAdapter::TableDefinition/27676712">Stack Overflow</a>.</p>
comments powered by Disqus